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INTRODUCTION

1.1 About Wink™

Wink is a software tool to make presentations and tutorials about using software
programs. A Wink presentation will resemble a live walkthrough about how to use the
software. Also the author of the presentation can add comments and explanations to
parts of the presentation to better explain the concepts and usage to the end user.

There are many purposes for these kinds of presentations:
e Advertising of software.
e Tutorials of software for classes.
¢ Documentation of software to supplement written documentation.
e Answer questions about the use of programs visually.

The basic output format of Wink is Flash. Flash is viewed in a web browser using the
free Macromedia Flash Player which is already installed on most computers or can
easily be installed the first the time the end user tries to watch a flash file.

Wink is actively in development and constantly improving. If you have a comment or
suggestion to make or an idea to improve, please make it public by posting in the
User Forums at " http://www.debugmode.com/userforums/".

1.2 Requirements

When working inside Wink the minimum screen resolution to be used should be
800*600 although it is recommended to use a screen resolution of 1024*768 or
better. This will make it easier to edit a presentation with a large area size because
you will be able to see full or at least a large part of the current frame.

The minimum and recommended screen resolution doesn't apply when you are

capturing screenshots for a Wink presentation. Screenshots could very well be
captured with a screen resolution of 640*480 depending on the needs.

1.3 Installation

The installation package comes as a zip file with the install file. Unzip this file into any
temporary folder and run the executable to start the installation. If you have an earlier
version of Wink installed, this installation may overwrite the settings of the earlier
install (similar to an upgrade).



1.4 New features in version 2.0

Wink has been completely rewritten for version 2.0. Currently version 2.0 is available
only for Windows; a Linux version will be available soon. The following is a list of the
most important new features in Wink 2.0 among many improvements, changes and
bug fixes.

Translated to more languages

Undo/Redo

Unlimited textboxes

Unlimited buttons

URL Buttons to open a webpage when clicked

Image objects

Shape objects, create and use shapes just like callouts with no text
Audio (can record while capturing, as well as add/edit later)
Improved and simpler properties panel

Improved flow of control in output swf file so no more flickering of title/callouts
when no buttons are used

e Ability to disable frames in a project so they won’t appear in output

1.5 Differences between Windows and Linux versions

Most of the Wink user interface and features are the same in Windows and Linux, but
there are a few differences. The key ones are listed below.

¢ No input-driven capture mode in Linux

e Text fonts in Windows and Linux will be different depending on what is
available in the system

e Ul widgets will be different in both platforms so there will be minor differences
in the functionalities

e Wink system tray icon in Linux will be available only if the window manager
supports the required extension

Please note that the Ul is very different between the latest Windows version (2.0) and
the Linux version (1.5). The above points still apply to the Linux Wink version 1.5.

1.6 Using this guide

This user guide is distributed as a PDF document so that it can be printed as a
manual if necessary. It is recommended that you read this document completely
before starting to use Wink so that you can work with ease. Also a printout of the
shortcut keys will be helpful.

Two tutorial projects are present in this distribution. Once installed, run Wink and
choose menu "Help > View tutorial 1". Answer Yes to render the tutorial. You will see
the tutorial right after the rendering is done.

The sample projects are named "tutorial1.wnk" and "tutorial2.wnk". These files are
present in the Wink\Samples folder. There is also a step-by-step tutorial later in this
document.



BASICS

2.1 How to use Wink

To create a new presentation in Wink you run your target software and take
screenshots with Wink (automatically and/or manually) of each action done in that
software. These screenshots will afterwards be put together by Wink into a
continuous movie in which each screenshot represents a frame. Frames can be
moved, deleted and copied inside the project and between projects.

The mouse cursor’s position is saved separately for each frame. This way Wink will
take care of making the cursor move smoothly between frames. You can also change
the position of the mouse cursor in any frame.

There are several advantages to record presentations using screenshots and not
recording the entire presentation as a single movie:

e ltis easier to capture screenshots because if you make mistakes (open the
wrong file, do the wrong action, forget what to do and thereby making a long
pause etc.) in the recording progress you just don't take screenshots of these
errors. If you were recording a continuous file you would have to be very
prepared in advance to avoid these kinds of recording mistakes.

e When editing the file afterwards there are fewer frames to work with and most
frames are important - that is to say that there are only few or none
intermediate frames that for instance just show the mouse cursor moving from
one place to another.

e The resulting flash file will also be smaller because there are fewer frames in
the presentation.

But in some cases it can be useful and easier to just record everything that happens
e.g. when drawing or typing text in a program. In this case Wink can be set to either
record continuously through timed capture with a certain frame rate or use input-
driven capture where screenshots will be captured each time you click with the
mouse and/or press a key.

After the recording is done you can edit the sequence of frames and add
comments/explanations to each frame as necessary. You can add Previous and
Next buttons to pause the presentation and the user can then go back and forward in
the presentation by clicking these buttons. You can add Goto Frame buttons that
jump to other sections in the presentation. These help to create more advanced
presentations with different flows through the content instead of just going from start
to finish.



You can customize/personalize the presentation by choosing a static background
image for the entire presentation. This can contain the name, logo, copyright
messages etc. of the author and/or company.

In order to make consistent presentations you can create templates based on one
presentation and then apply this template to all other presentations. This way it is
easy to get the same look across presentations and you don’t have to do the same
customisations each time.

Once you have finished creating and editing a presentation, it must be rendered to a
flash file that for instance can be placed on a website or distributed in other ways for
the end users/customers to see. The quality and size of the presentation can be
adjusted through the number of colours used and the chosen frame rate of the flash
file. It is also possible to add both a preloader and control bar to the rendered
presentation. A preloader will be shown when the presentation is loading while the
control bar shows the progress of the actual presentation and makes it possible to
pause at will.

The presentation can also be exported to a HTML, PDF or PostScript file. These
exported files can be placed together with the rendered flash file on a website and
the end user will then have the option to print the presentation. Each frame in the
presentation will become a single image with the comments/explanations and buttons
that have been added in Wink. All buttons will still work in the exported files and will
jump to the corresponding place (HTML) or page (PDF, PostScript) in the file when
clicked.

2.2 Your first Wink project step-by-step

This section will guide you through the process of making your first Wink project. We
will make a short presentation that shows how to change the file view in Windows
Explorer from icons to details. You can also find a Wink project for this tutorial named
“tutorial1.wnk” in the folder "Wink\Samples”.

1. Preparing Windows Explorer and Wink for capturing.

1.1. Open Windows Explorer because this is the program we want to show in the
presentation.

1.2. Start Wink and create a new project using the menu “File > New”. This
brings up a wizard that by default sets Wink to capture screenshots of the
entire screen. One of the options in this step is to change the capture region
to a specific window or part of the screen (rectangle). For this project we will
capture the region of the Explorer window so choose the window option.

1.3. Click the "Hide Wink Window” checkbox to see the Explorer window which
was hidden behind Wink.

1.4. Click the “Choose” button, move the mouse to the title bar of Windows
Explorer and left click to select this window.

1.5. Press OK.

2. Minimize Wink to the system tray (the bottom right corner of screen) by clicking
“Minimize to Tray” and we can now take screenshots by pressing the default "Alt
+ Pause" keys for input-driven capture to make Wink automatically capture
screenshots for each mouse click and key press. When using this option you
rarely have to think about taking screenshots yourself and the project will typically



also end up containing a few more frames than if you captured manually because
more details are recorded.

Start the input driven capture by pressing Alt + Pause simultaneously. The
system tray icon changes to reflect that we are now using the “input-driven”
mode.

3.1 Minimize all windows except Windows Explorer. Place the mouse cursor
somewhere in Windows Explorer. The capturing does not start until you click
inside the target window. Start by clicking at a random place inside the
capture area.

3.2 Move the mouse cursor to the “View” menu in Explorer.
3.3 Open the menu by left clicking.
3.4 Move the mouse cursor to the “Details” menu option.

3.5 Click the mouse to select the Details option. This changes the view to details
view.

3.6 Stop the input-driven capture mode by pressing Alt + Pause again.

Now we have finished capturing frames. so right click on the Wink icon in the
system tray and choose "Finish Capture".

Wink will now display the current project. The larger top part of the window shows
the last frame in the sequence. In the bottom you can see all frames in the
sequence/presentation. The captured mouse cursor is visible with a box around it
to easily identify it from the real cursor. In the other frames you will be able to see
the progress of the presentation and the movement of the cursor.

First we will add a textbox to the first frame explaining what this presentation
shows. The textbox displays text in a popup balloon-like element called the
Callout. A Callout is a group of shapes created using the built-in Callout Editor.
Wink comes with many pre-defined callouts you can choose between for the
textboxes used in frames, and you can create your own callouts using the Callout
Editor.

Select the first frame in the thumbnail list shown at the bottom of the window.
Now go to the Properties bar (the bar on the right of the Wink window) and click
the Add Texbox button. The textbox will be displayed with a default (the last
used) callout in the frame. You can now double click the textbox in the frame and
type the text (something like "How to change file view in Windows Explorer")
inside it. You can resize the callout in the frame, move it to another position,
choose another callout by clicking the button showing a speech bubble and edit
the font by clicking the button showing an F.

Now we will add a Next button that the end user can use to start the presentation
and a Goto button to return to the start from the last frame (in this simple
presentation a back button would also return to the first frame). Select the first
frame in the sequence and click the Add Next button in the properties bar. The
newly added button is by default placed at the center and you can move it to any
place you desire.
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In frame 5 we will set a value for how long to stay before continuing

to frame 6. This way the viewer gets time to comprehend what option we

are clicking in the presentation. Change focus to the “Stay in this frame for” box
located on the Properties bar and type in the value 1.

Select the last frame and click the Goto Frame button in the properties bar. Then
select the frame it should go to (in this case it is frame 1).

. To tell the end user what this Goto button does, we will add a textbox to this

frame with the text “Replay presentation”. The text box and the Goto button
should be placed so that the button is inside the text box area either to the right of
or below the actual text.

Before going further we will save the project using the menu "File - Save”. You
should save your project often when editing the project.

Choose menu "Project = Settings”. Type the name for the output flash file (for
instance "Explorer_views"). If you just specify a filename, the output flash file will
be saved in the folder where the project is saved (or the desktop if you haven't
saved the project yet). Press OK when you have typed a name.

Choose menu "Project = Render” or press the green arrow in the toolbar to
create the presentation as a Flash file.

Congratulations - you have made your first Wink presentation. You can view it
through “Project = View Rendered Output”. This will open your browser and you
should see the presentation being displayed or if you do not have Macromedia
Flash Player installed you would get an option to install it.

In the folder where the flash file was generated/saved you will see that besides
the actual flash file Wink also generates a HTML file with the same name to open
the flash file in the correct size. When putting a presentation on a webpage you
should link to the HTML file and not directly to the flash (swf) file.

You have now seen and tried some of the options in Wink. Continue reading the next
chapter to get more information about the user interface and options in Wink to
improve your skills in making great Wink presentations.



USER INTERFACE

3.1 Basic Ul

When you first start Wink you will see a menu and a toolbar at the top of the window.
To the right is the Properties bar where individual and common properties for all
frames are accessible. It is possible to see and edit the position and properties of all
elements added to a frame.

The language used in the user interface can be changed from the menu “File >
Choose Language”.
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The project window is divided into two parts:

e Inthe work area at the top you see the currently chosen frame in normal size
and the elements that are added to the frame can be moved and resized with
the mouse.

e The thumbnail list at the bottom shows thumbnails of all the frames in the
current project. You can drag-and-drop frames within this list or between
projects and select which frame you want to edit in the work area.

More than one project can be open simultaneously in Wink, which makes it possible
copy frames between projects.

3.2 New Project Wizard and capturing screenshots

3.2.1 Step 1 - Setting up the project
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When creating a new project you will see the "New Project Wizard" with options to
start capturing screenshots or just create an empty project.

Normally you would want to capture screenshots for the new project through Wink. If
you just want an empty project you must uncheck the "Start by capturing
Screenshots" option. An empty project is useful if you want to copy frames from other
existing projects or if you already have captured screenshots as single images with
another program and now want to use them in a Wink project.

When creating a new project you can capture audio along with the screenshots (or

you can add audio later). Use the ‘Record Audio’ option to enable/disable audio
capture.

E3nNew Project Wizard - Step 1 of 2 E |
—

A;\ File Edil; [V Start by captuing screenszhots
< [ Hew,

E’/, I™ Hide Wink \Window
.;-:’..":_’ IScreen j Choose |

Fiegion : |n |n " |1 023 |?E?

Size:  [1024 » 7EB)

Current Mouze Pozition :

Timed Capture B ate |4 Iframes 4 zecond j

Input-Driven Capture &t W Mousze Click W Key Press

Ok I Cancel |

When capturing screenshots with Wink there are 3 ways to specify the capture area:

e Screen: The entire area of the screen.

e Window: Use the Choose button and a rectangle will show the area of the
window/program being captured. If you want to capture an entire window you
should move the mouse cursor to the window’s title line.

e Rectangle: Use the Choose button to draw a rectangle around the area that
must be captured or use one of the supplied default sizes.

To easily identify the area that should be captured for the project you can click the
"Hide Wink Window" checkbox. (This will not hide the New Project Wizard dialog.)
After defining a capture area (except the entire screen) you can still easily adjust the
chosen area by dragging the green borders identifying the area or by editing the
region values in the dialog.

At the bottom of this dialog you can change settings for the two automatic capture
modes. For timed capture it is possible to define how often captures should be made.
This can be a rate of a number of frames per second, minute or hour. Regarding
input-driven capture this can be set to capture screenshots at all mouse clicks and/or
all key presses.
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Press OK to go to Step 2 of the New Project Wizard (if you have chosen to capture
screenshots). If you deselected the checkbox for "Start by capturing Screenshots"
you will be brought back to Wink and see an empty project.

3.2.2 Step 2 - Capturing screenshots
Wink is now in capture mode. You can see the hotkeys available to either capture

screenshots manually or start/stop one of the two automatic capture modes. In the
bottom of the dialog you can see how many frames have been captured until now.

HNEW Project Wizard - Step 2 of 2 Ei |
]

File Edit| “You are now capturing screenshots for pour Wink, project.
M “Y'ou can minimize thiz window, switch to vour application
New.|  and capture the screenzhotz az you are working o ik,

Choosge the Finizh button below bo end capturing.

Hatkeys :
To take a screen snapshat - Pauze
To start/stop timed captures - Shift + Pauze

To ztart/ztop input-driven captures - Al + Pauze

Frames captured: 0

Eirnzgh Cancel

In most cases you would now want to minimize Wink to the system tray so that Wink
itself isn't visible in the screenshots.

When minimized Wink is shown as an icon in the system tray. You can right click this
icon to capture a screenshot, finish the capture session, cancel the capture session
or restore the capture window (to see how many frames have been captured).

There are 3 different way to capture screenshots for a project and you can change
between them in the same capture session.

- Manual screen snapshots — Each time you press the hotkey (default:
Pause) the current content of the screen is captured to a frame in the
project. The Wink icon in the system tray will blink momentarily to indicate
this. If you want to use this mode exclusively you have to take
screenshots after all actions done with the mouse and keyboard and
furthermore also each time the mouse cursor has moved from one
position to another.

e Timed capture — When activated with the hotkey (default: Shift + Pause)
Wink will continuously capture screenshots with a certain capture rate that
is specified in the previous step until you stop it again with the same
hotkey. The Wink icon will be replaced by an animation that updates with
the speed of the capture rate. For tutorials it is not very efficient to only
use this mode because it will quite certain record many unnecessary
frames but it can be effective for small parts of a project showing for
instance how to draw in a program. This mode is also useful for tracking
the behaviour of programs/installations that runs for a long time. In this
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case you could set the capture rate in the previous step to only record a
given number of frames per minute or hour instead of frames per second.

= Input-driven capture — Using input-driven capture Wink will automatically
try to capture all the relevant frames while you do the actions that should
be recorded. It can record all mouse clicks and/or all key presses (with the
exception of some default and user-defined key combinations) based on
the choice in the first step of the wizard. This mode is started and stopped
through a third hotkey (default: Alt + Pause) and the icon in the system
tray will change to show when it is activated. Like with manual screen
snapshots the icon will blink each time Wink captures a screenshot but in
this case not all the screenshots are actually converted into frames in the
project since Wink will only save a screenshot if it is different from the last
one.

When using input-driven or timed capture mode, you can force captures at any time
using the manual screenshot hotkey.

When you have finished capturing screenshots you must right click the Wink icon in
the system tray and choose Finish (or Restore Capture Window and press the Finish
button here). This will end the capture session and you will see the project window. It
will take a little while to generate all the thumbnails depending on the number of
frames and the speed of your computer.

If you choose to cancel the capture session no new project is created and all
captured screenshots will be lost.

3.3 Project Settings

Project Settings can be opened through the menu “Project - Settings”. In the first
field you must specify the name of the output flash file to create when you render the
project. If only a file name is specified the file will be created in the folder of the
project file (or the desktop if you haven’'t saved the project yet).

Project Settings E
Output File Mame ISEIITID|E-SWf Browze |

Dutput File Type IMachmedia Flash [*.zwf] j

¥ Use Palette [reduces filesize]  Add preloader to flash output W Chooze

¥ Enable Audio Output &dd control bar to flash output W Chooze |
Frame Rate ITZI Curzar Movemnent S'Tjth Flough

(] I Cancel |

Output file type can be Macromedia Flash (.swf) to show on web pages, a self-
playing Flash executable (.exe) that you can view directly on any PC or a
uncompressed Flash animation (.swf) which can be imported in other Flash tools.
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The Use Palette option specifies if the project should use a Palette when generating
the flash file. Without using a palette the presentation will use all the colours seen in
the individual frames. By adding a palette Wink reduces the total number of colours
used throughout the presentation to a maximum of 256 colours. (You can define the
number of colours in a palette to be between 1 and 256 colours.)

The purpose of reducing the number of colours is to reduce the file size of the
rendered flash file. Dependent on the number of colours in the frames you might not
be able to see any difference in the rendered presentation than if not using a palette.
If there are photos or gradients between colours in any frames the effect of using a
palette will be more visible in the presentation. The creation of the actual palette is
shown in the next section.

The Enable Audio Output option is used with projects containing audio and specifies
if Wink should include audio in the outpuit file. If this option is not enabled the
project’s audio will not be included in the output This option is not available for
projects that do not contain audio.

The Add preloader to flash output option is used to choose if a preloader will be used
in the output file and if so which preloader will be used. To choose a different
preloader click the Choose button. In the Choose Flash Preloader window you can
choose one of the available preloaders, create a new preloader or edit the preloader
of your choice. For more detailed information on the Flash preloader see section
3.10.1.

The Add control bar to flash output option is used to choose if a control bar will be
used in the output file and if so which bar will be used. To choose a different control
bar click the Choose button. In the Choose Flash Control Bar window you can
choose one of the available control bars, create a new control bar or edit the control
bar of your choice. For more detailed information on the Flash control bar see section
3.10.2.

Frame Rate determines the speed of the presentation in frames per second. This
setting is highly related with the Cursor Movement setting. So if you want smoother
cursor movement and move the slider to the left you will also have to increase the
frame rate to make the mouse cursor have the same speed in the final presentation
as the original setting. For a more thorough explanation see the gray box below.

The connection between Frame rate and Mouse Cursor Movement

If the mouse cursor moves from one position to another between two frames, Wink will
generate intermediate frames while rendering to show the cursor movement. A more smooth
Cursor Movement setting will generate more intermediate frames. But if we add more
intermediate frames and don't increase the frame rate correspondingly the movement of the
cursor in the flash file will also be slower.

For instance if Wink normally generates 16 intermediate frames between 2 frames in the
project and we use the default frame rate of 8 frames per second it will take 2 seconds for the
cursor to move from the start position to the end position. If we now change the Cursor
Movement to be smoother Wink may now generate 32 intermediate frames between the 2
original frames. With the default frame rate of 8 frames per second it will now take 4 seconds
for the cursor to move from the start position to the end position. If we want the final
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presentation to keep the same speed as with the original smoothness setting we will have to
change the frame rate to be 16 frames per second instead.

This relation is described in the following formula:
Frame rate / Smoothness of cursor movement = Speed of mouse cursor in presentation

Higher frame rate - Faster mouse cursor
More smooth cursor movement - Slower mouse cursor

3.4 Palette

If you have chosen to use a palette in the Project Settings you can create or edit a
current palette by choosing menu “Project - Edit Palette”. Also if you have chosen to
use a palette but have not created one before rendering you will be shown this
dialog. For best results postpone the palette creation until all editing in the project is
done.

The first time you will see an empty palette. You can actually change the number of
entries and choose each colour manually but that is not recommended. Click the
"Create New" button and let Wink create the palette from one of 4 methods.

e Histogram + Optimized Octree: This is the recommended setting to use as it
normally gives the best result for the rendered output. V4 of the palette is filled
with the most frequently used colours in the frames (using a histogram) while
the rest of the palette is based on an optimized octree calculation.

e Optimized Octree: With this setting the entire palette is based on an optimized
octree calculation and the result is normally also very good but sometimes
there can be problems with frequently used colours in the rendered output.

e Web-Safe 216 colours: Standard colours used and supported by all browsers
and web tools.

e Windows Standard 16 colours: If you want to support old systems that can
only show 16 colours.

Create New Palette Ei |

— Chooze creation method

& Histogram + Ophmized Octree € Optimized Octres

™ wWeb-zafe 216 colours = Windows standard 16 colours
Humber of entries |255 Compute uging © Current frame anly
& Al frames

] I Cancel

For both “Histogram + Optimized Octree” and “Optimized Octree” you can choose
how many colour entries there should be in the palette. The default setting of 256
entries and the option to use all frames should be the best setting in almost any case.

When the palette is created you can edit the individual colours by double clicking

them. You can also save and load palettes. This can be useful if you are trying to see
the effect of different palettes in the rendered presentation.
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3.5 Editing frames in a project

Most of the time spend in Wink will be
used to edit frames in the project i.e.
adding/removing elements to the frames.

Almost all options regarding this are
available in the properties bar (Some are
also available in the menus and a few are
only available through the menus). The
properties bar can be displayed through
the menu “View > Properties Bar”.

Properties of each element in the frame
can be viewed/modified by selecting the
item in the list. You can also modify the
position/properties of elements, layer
objects of the same kind, enable/disable
objects and entire frames across multiple
frames in a single step. See the Tips and
Tweaks chapter to learn how to do this.

3.5.1 Frame Titles

Froperties for frame 1

Title IThiS iz the first frame's title

Stay in thiz frame for ID-':":I ZEC.

+':(]']j +E +% + + + %E RE

Frame
Audio (0,75 sec.)
Cursor

Puozition: I I % I I

Layering: ﬂ ﬂ

Properties; <nones

Properties common far all frames
T Background | [
¥ Frame Tiles F | =~

Positian: |5|:| |5E| :-<|24E| IEEI

Frame titles are used to display a title/headline for individual frames. They can be
enabled for all frames using the checkbox in the common properties section of the
properties bar. You can change the font used for titles using the choose font button
(F) and alignment of the titles using the alignment button (next to the choose font

button).

The actual title for the current frame is typed in the Title field at the top of the
properties bar. By default the field for the frame title field is placed in the top left area
of the frame (50 pixels to the right and 50 pixels down from the top left corner) but
you can move and resize it as needed by using the resize handles or using the
Position fields to enter new pixel sizes. Titles appear in the same position in all

frames.

If you haven't typed a title for the current frame you will see the text: "The frame's title
will come here...”. This default text will not be displayed in the rendered flash file.

3.5.2 Stay in this frame for time

This field is used to add a pause for some time before showing the next frame. When
adding small pauses between frames it gives the end user a little more time to
comprehend what is being shown in a presentation and it can also be useful to make
the presentation look more real. The pause value is specified in seconds (e.g. 1.5

seconds).



3.5.3 Add Audio

The Add Audio button opens the Audio Editor window. This window allows you to add
audio files in WAV (.wav) and MP3 (.mp3) formats, record audio for the frame, play
the audio file associated with the frame and adjust record/playback settings.

Audio Editor E3

F H|[o X [@®[» =8 @

Position:  0.00 / 0.63 sec.

Cancel |

You can use the audio editor to do the following:

1. Record audio (using the red Record button in the middle): this will start
recording audio until you click the stop button.
Play existing/recorded audio (using the Play button)
Import audio from external .wav and .mp3 files
Export/save audio to external .wav files
Delete unwanted regions from the audio stream: to delete a block of audio,
you first have to select the block of audio by clicking at the start of the region
and dragging the mouse until the end of the block to delete. The selected
block will be shown in a different colour. You can delete the selected block of
audio by clicking the red Delete button, and to undo a previous delete use the
Undo button. Typically this is used to delete silence regions in the audio.

A A

Note: When importing audio from an external .wav or .mp3 file, Wink will read the
audio at a sampling rate of 11025 Hz and will display a warning message if the
original audio did not match this rate. This sampling rate of 11025 Hz is sufficiently
good for speech and other related sounds (but not for music) so if the imported audio
does not sound as good as the original, please convert the audio externally to this
sampling rate and then import into Wink.

3.5.4 Add Image

The Add Image button allows you to add an image to the frame. In the Properties
bar choose the Add Image button. You now have the option to browse to your image
and click Open. The image is now located within the frame. You now have the
options to move or resize the image. To move the image, place the mouse over the
image, hold down the left mouse button and move to the desired position. To scale
the image hold down the Shift key and drag from the side of the image, not the
corner. The image will resize the same amount on all sides. If you drag from the
corner, the image may look distorted as the scale will not be proportional.

The opacity of the image can be changed by entering a number in the box beside %

opaque on the Properties bar. If you choose to reset the image to it’s original size,
click the Reset to original size button.
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3.5.5 Add Preset Shape

The Add Preset Shape button opens the Choose Preset Shape window which allows
you to add a shape to the selected frames and create/edit shapes.

Choose Preset Shape [ x|

 Preview
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Edit

Create Copy
Thick Border

Thin Border
Fill=d
Shadow
Magnifying Glass
Rectangle
Rounded Rectangle
Signs

Smiley LI
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Delete
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(1] Cancel

To add a shape click the Add Preset Shape button in the properties. This opens the
Choose Preset Shape window where you can choose between the available shapes
and see a preview of them. You can also create new and edit existing shapes
(described in the next section). The order of shapes in the tree is defined through the
name of each shape where dots ’.’ splits the name into folders, subfolders and the
actual shape. So for instance the name "Arrow.Down.Thin Border” first creates a
folder named "Arrow”, under this you will find a subfolder called "Down” and finally
the actual shape is called "Thin Border”.

To change a shape double-click itself in the main view or select the shape in the
main view and click the Choose Shape button located on the properties bar. Both
options will open the Choose Preset Shape window. Also located on the properties
bar are options that allow you to set the opaque of the image, placement and size of
the image as well as changing the colours.

3.5.6 Add Textbox

Textboxes are often the most important element in a presentation because they allow
you to increase value by adding comments and explanations to the content in the
individual frames.

A textbox consists of a callout and the actual text. The callout is the graphical shape
inside which the text is placed and it can be anything from a plain rectangle to fancy
speech bubbles. A number of standard callouts are supplied with Wink but it is also

possible to design your own callouts with the Callout Editor.

You can add/remove a textbox in a frame by clicking the button in the Properties Bar.
A new textbox uses the same callout that was used last time. The textbox can be
moved and resized using the mouse or by editing the position values in the advanced
properties bar.
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To add/edit text in a textbox you can either double click it in the frame or click the
Add Textbox button in the properties bar. When editing a textbox a toolbar will be
shown right above the text area allowing you to easily change font, font size, font
colour and if the text should be bold, italic or underlined. Each of these options
always works for the entire text in a textbox. Clicking outside the textbox after editing
or clicking the diskette button in the toolbar keeps the changes made and clicking the
red X will cancel changes to the text. If you have added more text than can fit in the
textbox Wink will automatically resize it when you decide to keep the changes.

You can change the text font while editing the text and also by using the choose font
button (F) in the properties bar. Finally the alignment of the text in the textbox can be
changed using the text align button in the properties bar. Textboxes can also be
copied between frames like other elements.

You can change the callout using the button showing a speech bubble in the
properties bar. This opens the Callout Chooser where you can choose between the
available callouts and see a preview of them. This window also allows you to create
new and edit existing callouts using the Callout Editor described in the next section.
The order of the callouts in the tree is defined through the naming of each callout
where dots ‘.’ splits the name into folders subfolders and the actual callout. So for
instance the name “3D Box With Arrow.Yellow.Left” first creates a folder named “3D
Box With Arrow”, under this you will find a subfolder called “Yellow” and finally the
actual callout is called “Left”. The <Legacy ltems> folder contains callouts to support
wink projects created in version 1.0.

= 30 Box [ Edit |
Gray . -
B Yellow 'our kest will come here... Create Mew |
Rounded
Straight Create Copy |
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3D Moke
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] | Cancel |

You should accompany textboxes with either Next/Previous (and/or Goto) buttons to
pause the presentation or add a large value (many seconds) in the "Stay in this frame
for time” field.

3.5.7 Shape and Callout Editor

The Shape and Callout Editor is accessible from the Shape and Callout Chooser
window when you click either the Edit button to alter an existing shape or callout or
Create New to make a new shape or callout from scratch. This is a somewhat
advanced tool to design your own shapes and callouts. It might take a little while to



grasp the Shape and Callout Editor but when you have learned how to use it you can
make all kinds of fancy looking shapes and callouts.

The Shape and Callout Editor consists of a toolbar at the top, a work area at the left
and a properties bar at the right. At the top of the properties bar you can see a list of
all the shapes in the callout you are editing. When you select a shape in this list it will
also be selected in the work area and you can see the properties of the shape below
the list and modify them. Shapes can also be selected directly in the work area.

To draw in shapes and callouts Wink provides these tools.

O Rectangle - To create a rectangle shape click on a place in the work
area, drag the mouse and release the mouse button in the second
position.

o Ellipse - Drawing an ellipse is similar to drawing a rectangle.

s Polyline - Using this tool you can create a shape by drawing a set of
connected lines. To start drawing click a place in the work area and the
first line starts. Move the mouse to the second position and click, this
will end the first line and start the second line from this position. Do this
repeatedly until you have created the entire shape. To finish drawing the
shape, click the right mouse button.

(& Curve - This tool allows drawing any kind of shape and creating the shape
as a curve. You can modify this curve later as you want. To draw a
curve shape click on a place in the work area and draw the full Shape
while keeping the mouse button pressed, and release the button after
you have finished drawing.
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To modify existing shapes Wink provides these tools.

i Edit - This tool allows editing a shape at the basic level, by modifying the
points of the shape. If the shape is a line shape (i.e. a polyline or a
rectangle), you can edit the end-points of each line. If the shape is a
curve (ellipse and curve), you can edit the control points of the curve.
You can add new and delete old points on a shape by right clicking an
existing point on the shape and choose the options from the menu.

& Transform - This tool can move and resize a single shape at a time. Just
select the shape you want to edit, and use the frame around the shape
to move and resize it.

fan Rotate left - Rotates the selected shape 90 degrees counter clockwise.

an}. Rotate right - Rotates the selected shape 90 degrees clockwise.

€3 Mirror - Mirrors the selected shape.

& Flip - Flips the selected shape.

Each shape has properties for line width, line colour and fill colour. Fill colour is by
default a single colour but clicking a checkbox can change this to be a gradient
instead. For gradients there is a start and an end colour and through the gradient
direction values you can change both the direction and how dominant each colour
should be. The percentage value behind each colour determines the transparency so
it can be made possible to see some of the other shapes behind the current shape.
The Closed checkbox determines if the line that makes up the shape should be
continuous — that is if the start and end point of the line are connected. The shapes
will be added to the list in the order they are added to the shape or callout. This order
is important to get the correct effects. Latter shapes in the list are drawn on top of
earlier shapes in the work area.
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The last shape (Text Field) in the list is special since it is only used to specify where
text can be written inside the callout. The only thing you do to this shape is to change
its position and size in the callout. It cannot be deleted. The default colour of the text
can also be set right below the shape list. This colour is overridden if you choose
another colour in the font dialog for the individual textboxes.

The Intelligent Resize option deals with making sure that a shape or callout still looks
good when resized to other sizes than how it was originally created. Basically without
this option there will often be problems with any shapes or callouts that is not a basic
rectangle because the corners and ornaments that are added to a shape or callout
will be resized along with the size of the shape or textbox. When Intelligent Resize is
activated Wink will do the best it can to preserve the look of the edges, corners etc.
when the shape or textbox is resized.

There are two types of shapes: shapes created with lines and shapes created with
curves. Polyline and rectangle are shapes created with lines while ellipse and curves
are (Bezier) curves. A line-based shape has end-points, whereas a curve shape has
control-points.

Finally the Shape and Callout Editor has some basic tools to undo/redo the last
actions, the options to delete, cut, copy and paste the shapes in a shape or callout
plus the choice to zoom in and out on the work area.

3.5.8 Cursor

When capturing screenshots using Wink the mouse cursor is displayed in the correct
position for the individual frames. To make it easy to separate the actual mouse
cursor from the cursor in the frame the latter is surrounded by a little box. You can
move the cursor anywhere and enable / disable it, as you need.

You can change the cursor image in a frame by double-clicking the cursor element or
by selecting it and clicking the Choose Cursor button in the properties bar. You can
choose from all the pointers in the currently used pointer scheme (this can be
changed in Windows Control Panel) and user defined pointers.

Choose Cursor
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You can export existing cursors to png images and import new cursor from icon
(*.ico) and cursor files (*.cur) or gif and png images.

Export to...
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e
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3.5.9 Next/Previous Buttons

When a Next and/or Previous button is displayed in a frame the presentation will
pause and the user has to click one of the buttons to continue. This gives control to
the users and enables them to go through a presentation at their own pace.

A Next button will continue directly to the next frame in the sequence while a Back
button will go back to the previous frame with any type of button.

Like the other elements in a frame you can enable/disable each type of button by
clicking their checkboxes in the properties bar and by default they are placed in the
center of the frame. They can be moved by dragging them around in the frame or by
editing their position values in the properties bar. The buttons can be placed in
different positions on each frame.

You can use your own images for the buttons by clicking the Choose Image button at
the bottom of the properties bar to change the image. A lot of formats are supported
for the buttons including PNG images and icons where you can have transparent
areas with full alpha channel to enable the use of cool looking buttons.

3.5.10 Goto URL Button

The Goto URL button is used to open a webpage when clicked. When you choose
the Goto URL button on the Properties bar the Specify URL to launch window opens.
Enter the URL in the URL to launch field. Leave the next field blank if you wish the
URL to open in the current browser window. If you wish the URL to open in another
browser window enter the correct standard HTML window name. It is also possible to
enter email links that open in the users email program (mailto:email@address.com).

3.5.11 Goto Frame Button

The Goto Frame Button can be seen as a general-purpose version of the
Next/Previous Buttons and you decide which frame the Goto Button should jump to.
This enables the creation of more complex flows though a presentation than just a
linear flow from start to finish.

For e.g. If you are showing two ways to do a particular action in your presentation,
you can capture screenshots of both ways and give the end user the option to
choose which way he/she wants to see. Another use would be if there is both some
basic knowledge and more advanced knowledge in a presentation. Here it would be
possible to make the option to jump directly to the advanced knowledge if the user
already knows the basic stuff. Finally when reaching the end of a presentation it
would be obvious to create a Goto button that goes back to the first frame and in this
way becomes a restart button.
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Each time you use a Goto button it is recommended that you refer to it from a textbox
to tell the end user what it does. See examples of this in the included tutorial files.

When you decide to move some of the frames in a project to another place in the
sequence of frames Wink will make sure that Goto buttons always points to the same
frames (by content not number) that you decided from the start. If you delete the
frame that a Goto button points to then the Goto button will also be deleted.

Like with the Next/Previous Buttons mentioned above you can also change the
image used by each Goto button..

3.5.12 Background Image/Colour

The purpose of adding a background image or background colour is to further
customize the presentation to your needs. You can have a logo, name or copyright
notice showing all through the presentation or add a background that looks like a TV
set and use Next/Previous buttons as the TV's controls while showing the actual
presentation on the screen.

A background image or colour is added to the presentation using the button at the
bottom left of the properties bar or through the menu “Project > Choose Background
Image”. You can choose between a simple solid background colour or load an image
file created in another program.

When using a simple colour background you must specify how large the background
area must be and the fill colour. The size of the background area must be at least the
size of the frame images in the project. Information about the size of the frame
images can be seen in the status bar at the bottom right of the Wink window or be
found through the menu “Project - Information”.

After having added a background image/colour you will notice that the frame
images/screenshots by default is placed at the top left corner of the background
image/colour. To change this position you can drag the frame image by its border or
edit the Frame Position values in the advanced properties bar.

If you want to remove a background image/colour from a project you just have to
uncheck the checkbox for this option in the properties bar. Be aware that this
removes the background from the project and does not just disable it. If you want the
background back at a later time you have to choose the colour or load the original
image again in the Choose Background Image dialog.
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3.5.13 Shift All Elements

If all elements in all frames have to be moved to another position use the “Project >
Shift All Elements” dialog. You specify by how many pixels all elements (including the
frame image/screenshot) have to be moved. You can enter negative values if you
want to shift elements upwards or to the left. This option is only available when a
background image/colour is used in the project.

3.5.14 Crop All Frames

Crop means you remove part of all frames in the current project e.g. if you have
created a project based on screenshots of the entire screen, you might want to
remove the bottom part showing the taskbar. Use the “Project > Crop Frames”
dialog for this purpose.

The dialog displays the current size of frames in the project and you must then
specify the area to which you want to crop the frames. If you use a background
image/colour in the project Crop Frames won't affect the background but only the
frame images/screenshots.

3.5.15 Resize All Frames

Resize All Frames |

Rezize what?

f* Allelements € Only frame and cwrsar € Only frame

' Resize to percent I'IEIEI %

™ Resize to size

Ful size IEUU % |31 1] pixels

] | Cancel

This feature gives you 3 options on what to resize:

1. All elements in the project (with the exception of textboxes and frame titles)
2. Only frame and cursor
3. Only frame

You can enter either the percentage value or an exact pixel size for the new size. Be
aware that this feature will give the presentation a slight blurred look because the
sharpness of images will be lost when resized.

3.5.16 Insert and delete frames

New frames can be inserted in a project through the menu “Image - Insert Frames”.
You can insert frames before or after the current frame and they can either be a copy
of the current frame or blank frames (used to paste images/screenshots created by
other programs). When inserting blank frames into an empty project you will be
asked for the size of the frames to insert.
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You can delete selected frames using the delete key/icon or going through the menu
“Edit > Delete”.

3.5.17 Editing the sequence of frames

You can use standard drag-and-drop, cut, copy and paste tools to work with the
frames in the thumbnail list of the project.

When you copy a frame in the thumbnail view, all the elements (frame, buttons,
textbox, title etc.) are copied and when pasted it will create a new frame.

There is another option called Copy Merged in the Edit menu. This will merge the
frame and all elements into a single image. If you paste an image that has been
created by the Copy Merge option this image will not create a new frame but the
image will be inserted into the current frame and the elements will not be editable any
more as they are a part of the image. The purpose of Copy Merge is to copy an
entire frame with added elements to other programs like an image editor or word
processor.

3.5.18 Thumbnails Only View

When there are many frames in a project it can be useful to switch to the Thumbnails
Only view through the menu “View - Thumbnails Only” (or by double clicking/
pressing enter on one of the thumbnails in the sequence). Here you get an overview
of the entire project and it is easier to edit the sequence of frames. It is also an easy
way to find a specific frame you want to edit. You return to the normal project view
through the same menu option or double clicking/pressing enter on a thumbnail.

In both the Thumbnails Only View and when the thumbnails list is active in normal

project view you can easily navigate to another frame by just typing the number of
the frame you want to see.

3.6 Rendering the flash presentation

To create a flash presentation use the menu “Project - Render”. If you haven't
named the output file yet the Project Settings dialog will popup first for you to enter
the name. Also if you have chosen to use a palette but haven't created one yet, the
palette dialog will be shown for you to do this before starting to render.

Rendering creates either a flash (.swf) file with a corresponding HTML file (in the
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same folder) or a windows executable (.exe) depending on your choice in the Project
Settings. To view the presentation you can choose menu “Project - View Rendered
Output”.

3.7 Templates

One of the advanced features of Wink is the option to create templates with many of
the settings/properties that apply to a project. You can use templates to make
consistent presentations with the same look without having to do the same
customisations each time.

Not all settings/properties can be saved in a template because some settings will
seldom or never apply to all frames in a project or to more than one project. In the
schema below you can see which items that can be saved or not saved.

Templates are created based on the Choose &Template Items
settings of a chosen frame in the

project. So when you want to create a Vi S e e
template you first have to find (or ¥ Frame Position V¥ Mext Buttan Position
create) a frame with all the correct ¥ Title Enatile ' Mext Button Image
settings. Then use menu “Project > ¥ Title Fart & Style ¥ Previous Button Image
Save Template”. This opens the choose [ Title Pesition ¥ Frame Rate Sefting

dialog where you select what items to

! v v Llze Palette Setti
save in the template. Press OK and a @i W Use Palete Setting
Save dia|og will appear to Specify the v Texthox Font & Style ¥ Cursar Movement Setting
template file name. Templates are by
default saved in the “Templates” ok | Cencel |

subfolder in the Wink program folder.

When you want to apply atemplate to a [ ESETear ]
project (all frames) use the menu
“Project = Apply Template”. This will
show the Choose Template dialog.
Choose a template file and see a
preview of the current project with the
selected template. You can scroll
through all the frames in the current
project with the scrollbar at the bottom.
To select which template items to apply
you can use the “Template ltems”
button.

Template File:  zample.wtp

Freview

ok
Cancel

.

Note: All position items from a template are based on the size of the frame in the
original project from which the template was created. So applying a template to a
project with different frame size may not produce good results. If the size of the
current project is smaller than the original project some elements might even be
placed outside the viewable area.

3.8 Export/import text to and from file

All the text that you add to a project in textboxes and titles can be exported to and
imported from text files. This provides an easy way to translate or just proof read
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projects by exporting all the text, translate/proof read it externally in a text editor and
then import it back into the same project.

If the changes you have made in the text file can’t fit in the project’s original textbox
Wink will automatically resize the callout when you import the text. Though it can still
be worthwhile to do a quick look over of the frames with textboxes afterwards to see
if they still look fine.

Note: If you decide to edit the text file in a word processor like Microsoft Word you

have to save the document as plain text again. Otherwise Wink won'’t be able to read
it.

3.9 Export to HTML, PDF, PostScript and image files

Wink can export the project to HTML, PDF and PostScript files. This gives you an
easy way to present the subject to your end users in a format other than the flash
presentation. For instance some users may want to print the presentation, which isn't
possible with a flash file. If a HTML or PDF file is placed next to the flash
presentation on a website the users have more options.

The images in the exported file will look exactly like the frames in the project and the
buttons will still work in all the formats.

HTML Export Options PDF Export Options [ %]
g files... .
2 il Save azfile...

|sample.htm Browsze |
Itest.pdf Browse |
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MHote:  To wiew the project in a webpage, choose either BMP, Landscape Mode i

JPG or PHNG format in the above list.

Ok I Cancel | ()4 I Cancel |

When exporting to HTML you have to choose the format used for images (the images
are saved as separate files). The best image format for HTML files is PNG (for
screenshots of programs). If any frames contain photos then use JPEG.

Note: Use BMP, JPG or PNG formats if you want to be able to see the images in the
HTML file. Use the other formats to export frames and use in other programs.

For PDF and PostScript you have the option to decide the paper size and orientation
for the export, while the option to “Fit Page to Image” is limited to PDF Export. You
can also choose to not include buttons from the presentations if the exported
document is going to be printed.

3.10 Preferences

Wink’s preferences can be found in the menu “File > Preferences” where you can
specify some general settings for the program.
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5.

9.

10.

Thumbnail image size sets the maximum size the thumbnails can have (the
thumbnails will maintain the aspect ratio as the screenshots).

By default opening a Wink project from the file explorer while Wink already is
running will open it in the current instance of Wink. You can change this setting to
open a new instance instead. Remember you cannot drag-and-drop items
between different instances of Wink.

Wink will open the last used project at start-up but you can disable this action if
you often open Wink to create new projects.

Makes Wink save the project automatically before rendering.

Preferences |
1 Thumbnail image size [in pixels) IE::II w |6 ill
2 Hllow new instances when opening projects from file explorer [
3I:|:|au:l lazt project at startup v 5Eu:umgress fast while captuing v

4 Save project befare rendering [ 6 Show frame iconz in thumbnails [
? Kevs toignare when captuning in input-diiven capture mode Choose Eeys |

BEhange hotkeys far - Single frame capture | Timed capture | |nput-driven capture |

g&udiu tone to play after capturing a screenshot

| -

1 OE:-:ternaI HTHL wiewer path (leave emphy for spstem default]

| .

Ok Cancel

“Compress fast while capturing” improves capture efficiency while taking a little
more memory..

Frame icons are small icons below the thumbnails that show details about that
frame - if a value is specified in “Stay in this frame for time”, if any button is used
and if a textbox has been added for each frame. These icons can be very useful
to find the thumbnail/frame you want to edit. If both a value is specified in “Stay in
this frame for time” and one or more button is used in a frame you will only see
the button icon because the button overrides the “Stay in this frame for time”
value.

Input-driven capture can capture all keystrokes except modifier keys (Alt, Control
and Shift) used alone and Alt + Tab. Besides these keys you can add your own
keys/key combinations that should be ignored.

The default hotkeys for each mode of capturing can be changed to what you
want. (Some default windows hotkeys cannot be used.)

Specify a sound file to play when a captured screenshot is added to the project.
By default Wink will use the system default browser to display flash
presentations. If you want to use another browser specify the path here.

3.10.1 Flash Preloader

A flash preloader is displayed when the presentation is loading in a browser, so that
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the user knows that something is happening when loading big presentations. You
can choose from the default preloaders or create your own with menu Project >
Settings - Add preloader to flash output > Choose - Create New.
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A preloader can contain an image or colour background, a text label and a progress
bar.

At the top right of the Flash Preloader Editor you can choose a background image. If
you don’t choose a background image the background colour right below will be used
instead. Furthermore if the Text Label and/or Progress Bar are placed outside the
area of the background image you will also see the background colour.

You can enter position values or use the mouse to alter the placement of the Text
Label directly in the work area. The content of the Text Label is the text entered in
the Text String field and if wanted a percentage value showing how much of the
presentation is currently loaded. In order to separate the text and percentage value
you must simply press space a number of times after the actual text. The appearance
of the text is defined by the size of the Text Label, the 3 different flash fonts and the
colour of the text.

The Progress Bar can be placed in the same way as the Text Label and consists

basically of a coloured bar that can be smooth or split up into small blocks. This bar
can also be surrounded by an outline that has a line and background colour.

3.10.2 Flash Control bar
A control bar displays a progress bar in the flash output and lets the user pause/play

any time in the presentation and jump to any place by clicking on the progress bar
(only in flash swf file). Like with the preloader a number of default control bars are

30



supplied with Wink and you can create you own through Wink’s Project = Settings
- Add control bar to flash output > Choose = Create New.
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There are two differences between the use of a control bar in a flash swf file and a
self-executable exe file. In the swf file the play and pause button are overlaid each
other since only one is relevant at a time depending on the fact if the presentation is
currently playing or paused. It is also possible to click anywhere on the progress bar
in an swf file to jump to this place in the presentation. An exe file is limited in these
two cased as the play and pause buttons are placed separately and it is not possible
to click the progress bar to jump to another place in the presentation.

When editing (and choosing) a control bar you will see a preview displaying the two
possible states regarding if the play or pause button is currently visible. As said
above this preview is not correct if you render to an executable file where the two
buttons will be placed beside each other. In the edit window you can choose between
3 view modes displaying how the buttons will look when they are not touched, when
the mouse cursor hovers over them and when the buttons are pressed down.

The actual images used for all situations are chosen below. It is not necessary to use
all types of images for a control bar, as you also will be able to see in the supplied
default control bars. For the play and pause button you must supply an image for the
Normal mode while the MouseOver and Pressed images are optional. Regarding the
progress bar you would normally always use images for the Left, Right and Empty
Middle parts while it is optional if you will use either (or both) of the Thumb and Filled
Middle to show how far the presentation have come.

3.11 Shortcut keys

F3 Project Settings

F4 Program preferences
Ctrl + F4 Close project
Alt + F6 Switch between thumbnail and work-area panes
Ctrl + F6 Switch between open projects
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F3

F7 Render Project
F8 View Rendered Output
F12 Toggle Properties Bar
Ctrl + F9 Export Text to File
Shift + F9 Import Text from File
Ctrl + A Select all elements in a frame or select all frames
Ctrl + F Choose Textbox Font
Ctrl + J Current / Choose Frame
Ctrl + N New project
Ctrl + O Open existing project
Ctrl + P Edit Palette
Ctrl + S Save project
Ctrl +Y Redo
Ctrl + Z Undo
Insert Insert Frames
Delete Delete
Ctrl + X / Shift + Del Cut
Ctrl + C/ Ctrl + Ins Copy
Ctrl + Shift + C Copy Merged
Ctrl + V / Shift + Ins Paste
Alt + Ctrl + € First frame
Alt + € Previous frame
Alt + > Next frame
Alt + Ctrl + > Last frame
Alt + X Exit program

Project Settings

3.12 Toolbar

Here is a list of all the icons in Wink’s toolbar and what they do.

Create a new project

Open an existing project

Save the active project

Wink preferences

Undo (the last 16 actions)

Redo (the last 16 actions)

Delete the current selection

Cut the current selection and put it on the Clipboard
Copy the current selection and put it on the Clipboard
Paste Clipboard contents

Move to the first frame in the sequence

Move to the previous frame in the sequence

Move to the next frame in the sequence

Move to the last frame in the sequence

View/modify the palette for the current project
View/modify settings for the current project

Render the presentation from this project with the given options
View the rendered presentation

Displays the license and other information about Wink

SPLIOR =z 2a2@BPFeX0 5 »OND0



TIPS AND TWEAKS

4.1 Screen size of presentations

When creating presentations you should think about what screen resolution the end
users are likely to use. If the user views the flash file inside the browser they won't be
able to see the entire area if the flash file is the same size as the end users screen
resolution. Also the taskbar takes up some screen space. Therefore you should
always be sure to record the presentation in a smaller size than the screen resolution
the targeted users are likely to use.

For instance if you make a presentation based on the entire screen size and you
know that the end users are like to use a screen resolution of 1024*768, then set
your screen resolution (temporarily) to 800*600 when doing the capture. Afterwards
when editing inside Wink you can return to the normal (larger) resolution because
then you will be able to see the entire (or at least most of the) area of each frame,
which makes it easier to edit the project.

You also have the option to resize a project to a smaller area size. But this will also

give the presentation a slightly blurred look because it is not possible to keep the
images as sharp as the original screenshots.

4.2 Optimal use of input-driven capture

To get the best result from input-driven capture you should work slow doing the
actions that should be recorded since Wink might not be able to keep up with you.
This does depend on both the size of the area you are capturing and the speed of
your computer.

If the last action (mouse click) you have done with the mouse requires some
processing from the PC and there is a delay before the screen is updated, Wink will
miss a screenshot when the screen is updated. You can take a manual screenshot of
this step before processing with the next actions.

Finally when recording typing or other situations where the blinking text caret is
visible you will record extra frames because Wink will keep the screenshots even
though the only difference between frames is the text caret. To avoid this you can set
the text caret to not blink and always be visible through a Windows setting. In
Windows XP this setting is in the accessibility options while it is placed under the
keyboard properties on Windows 2000. These redundant frames could also be
deleted in Wink when editing the project afterwards but it is easier to not record them
in the first place.
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4.3 Edit multiple frames

One of the cool features of Wink is that you can edit the properties of multiple frames
simultaneously. If you select more than one frame/thumbnail in the sequence the
options changed in the properties bar apply to all frames. So you can change the
textbox font used in all marked frames and even more interesting when using the
advanced properties bar it is possible to align the position of, for instance, the Next
button across all selected frames by editing the position values in the properties bar.
If multiple occurences of the edited object type (e.g. multiple textboxes) is present in
any of the selected frames then the changes will only affect the frame currently in
view to avoid ambiguous changes.

4.4 Editing screenshots in frames

The screenshots originally captured by Wink can be edited afterwards by using an
external image editor of your choice. First select the frame/thumbnail with the
screenshot you want to edit and then select only the frame object in the properties
bar. You can now copy the screenshot by clicking Copy in the Edit menu or simply
pressing Ctrl+C. Now switch to your image editor, paste the screenshot and do the
editing. When you are satisfied with the editing, you copy the screenshot from image
editor, return to Wink and paste it back into the same frame (using menu Edit >
Paste menu or by pressing Ctrl+V).

4.5 Copy frames between projects

You can open more than one project simultaneously in Wink and copy (or drag-and-
drop) frames between projects. This way if you have created a project but you forgot
to take some more screenshots you can create the remaining screenshots in a new

project and copy these frames to the old project.

4.6 Optimize the size of presentations

To optimize the file size of presentations you should clean your desktop before
capturing screenshots. This also has the advantage that the end users watching the
presentation won't be distracted by other things you might have installed on your
computer. Some of the things to clean up are:

e Remove unnecessary icons from the desktop (copy them to a folder to easily
get them back).

e Disable wallpaper and use a single colour on the desktop.

e In Windows XP set the theme to “Windows Classic” instead of the default
“Windows XP”.

e Set the title bar of windows to a single colour instead of the default gradient.

e Disable the Quick Launch toolbar.

e C(Close all non-relevant programs (also in the system tray).

If you won't be showing the desktop or taskbar in the presentation some of these

suggestions obviously aren't necessary.

4.7 Maximize the space for showing presentations in a
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browser

To be sure that the end users can see the entire (or at least most of the) presentation
area you can disable all the elements that usually appears in the browser like the
toolbar, address bar, status bar etc. using JavaScript to open the browser window.

If you have a webpage from which the Wink-generated presentations are showed,
add the following script code somewhere inside the <head></head> element of that
webpage’s html source.

<script>
function WinkPresentation (file)

window.open (file, '"Wink', 'resizable=1,scrollbars=1");
</script>

The actual link that will open the html file with the presentation must be added inside
the <body></body> element of the html source. For example:

<a href="sample.htm" target="Wink"

onclick="javascript:WinkPresentation () ;">
Show sample presentation

</a>

In the example above “sample.htm” must be replaced with the name of the html file
generated by Wink and "Show sample presentation” should be replaced with the text
you want the user to see in the homepage describing the presentation.

4.8 Saving compressed projects

Wink projects can take a lot of space if they have a large number of frames, since all
of them are image/video data. When you have finished a project or if you want to
send a project to a friend, it is a good idea to save the project using the “File > Save
compressed” menu option. This will compress the project and save. Compressed
projects typically occupy 4 times to 20 times less space than normal projects. You
can compress them further using any zip utility.

Compressing projects and loading compressed projects take a significant time, so

use this only when necessary. All samples distributed with Wink are compressed
projects.

4.9 URLs of interest

DebugMode homepage  — http://www.debugmode.com/
Wink homepage — http://www.debugmode.com/wink/
DebugMode User Forums — http://www.debugmode.com/userforums/
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KNOWN ISSUES

5.1 Buttons in PDF files exported from Wink

When using Continuous view in Adobe Reader all buttons in a PDF file exported
from Wink will go to the page/frame after the actual frame they should go to. The
buttons work correct when Adobe Reader is setup to the default Single Page view.
This is an issue with Adobe Reader and not Wink and hopefully will be corrected in
future releases of Adobe Reader.

5.2 Flash output sometimes looks garbled with palette

This is due to a bug with the Flash player. You can either render the flash output
without a palette, or create another palette with a different number of colours to work
around this bug.
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